Как закрепить диапазон формулы в эксель кроме ф4

Как закрепить диапазон формулы в эксель кроме ф4

— Порядок ввода формулы

— Относительные, абсолютные и смешанные ссылки

— Использование текста в формулах

Теперь переходим к самому интересному — созданию формул. Собственно это то, ради чего и разрабатывались электронные таблицы.

Порядок ввода формулы

Вводить формулу надо со знака равенства. Это надо для того, чтобыExcelпонял, что в ячейку вводится именно формула, а не данные.

Выделим произвольную ячейку, например А1. В строке формул введем =2+3и нажмемEnter. В ячейке появится результат (5). А в строке формул останется сама формула.

Поэкспериментируйте с различными арифметическими операторами: сложения (+), вычитания (-), умножения (*), деления (/). Чтобы их правильно использовать надо четко представлять их приоритет.

— В первую очередь выполняются выражения внутри скобок.

— Умножение и деление имеют более высокий приоритет чем сложение и вычитание.

— Операторы с одинаковым приоритетом выполняются слева направо.

Мой вам совет — ИСПОЛЬЗУЙТЕ СКОБКИ. В этом случае вы обезопасите себя от случайной ошибки в вычислениях с одной стороны, а с другой — скобки значительно облегчают чтение и анализ формул. Если в формуле количество закрывающих и открывающих скобок не совпадает, Excelвыдаст сообщение об ошибке и предложит вариант ее исправления. Сразу после ввода закрывающей скобкиExcelотображает жирным шрифтом (или другим цветом) последнюю пару скобок, что очень удобно при наличии в формуле большого количества скобок.

Теперь давайте попробуем поработатьс использованием в формулах ссылок на другие ячейки.

Введите в ячейку А1 число 10, а в ячейку А2 — число 15. В ячейке А3 введите формулу =А1+А2. В ячейке А3 появится сумма ячеек А1 и А2 — 25. Поменяйте значения ячеек А1 и А2 (но не А3!). После смены значений в ячейках А1 и А2 автоматически пересчитывается значение ячейки А3 (согласно формулы).

Дабы не ошибиться при вводе адресов ячеек, можно использовать при вводе ссылок мышь. В нашем случае надо проделать следующее:

— Выделить ячейку А3 и ввести в строке формул знак равенства.

— Щелкнуть на ячейке А1 и ввести знак плюс.

— Щелкнуть на ячейке А2 и нажать Enter.

Результат будет аналогичным.

Относительные, абсолютные и смешанные ссылки

Относительная ссылкауказывает на ячейку, согласно ее положения относительно ячейки, содержащей формулу. Обозначение относительной ячейки — А1.

Абсолютная ссылкауказывает на ячейку, местоположение которой неизменно. Обозначение абсолютной ячейки — $A$1.

Смешанная ссылкасодержит комбинацию относительной и абсолютной ссылок — $A1,A$1.

Для быстрого изменения типа ссылки используется клавиша F4. Введите в ячейку А1 любое число. В ячейку А2 введите формулу =А1. Затем нажимайте клавишуF4. После каждого нажатия клавиши тип ссылки будет меняться.

Чтобы лучше разобраться в различиях ссылок, давайте поэкспериментируем.

Для начала разберем относительные ссылки. Введите в ячейки следующие значения:

А1 — 20 В1 — 200

А2 — 30 В2 — 300

В ячейку А3 введите формулу =А1+А2 и нажмите Enter.

Теперь установите курсор на правый нижний угол ячейки А3, нажмите правую кнопку мыши и протяните на ячейку В3 и отпустите кнопку мыши. Появится контекстное меню, в котором надо выбрать «Копировать ячейки».

После этого значение формулы из ячейки А3 будет скопировано в ячейку В3. Активизируйте ячейку В3 и посмотрите какая формула получилась — В1+В2. Почему так получилось? Когда мы записали в ячейке А3 формулу А1+А2, Excelинтерпретировал эту запись так: «Взять значения из ячейки, расположенной в текущем столбце на две строки выше и сложить со значением ячейки, расположенной в текущем столбце на одну строку выше». Т.е. скопировав формулу из ячейки А3, например, в ячейку С43, мы получим — С41+С42. Вот в этом прелесть относительных ссылок, формула как бы сама подстраивается под наши задачи.

Рассмотрим теперь абсолютные ссылки.

Введите в ячейки следующие значения:

А1 — 20 В1 — 200

А2 — 30 В2 — 300

Введите в ячейку С1 число 5.

В ячейку А3 введите следующую формулу =А1+А2+$C$1. Аналогичным образом скопируйте формулу из А3 в В3. Посмотрите что получилось. Относительные ссылки «подстроились» под новые значения, а вот абсолютная — осталась неизменной.

Попробуйте теперь сами поэкспериментировать со смешанными ссылками и посмотрите как они работают. Можно ссылаться на другие листы той же книги точно так, как и на ячейки текущего листа. Даже можно ссылаться на листы других книг. В этом случае ссылка будет называться внешней ссылкой.

Например, чтобы записать в ячейку А1 (Лист 1) ссылку на ячейку А5 (Лист2), надо проделать следующее:

— выделить ячейку А1 и ввести знак равенства;

— щелкните на ярлыке «Лист 2»;

— щелкните на ячейке А5 и нажмите клавишу ввода;

после этого будет активизирован опять Лист 1 и в ячейке А1 появится следующая формула =Лист2!А5.

Ссылка на ячейку из другой книги будет выглядеть так — =[Книга2]Лист2!А5.

Редактирование формул происходит аналогично редактированию текстовых значений в ячейках. Т.е. надо активизировать ячейку с формулой выделением или двойным щелчком мыши, а затем произвести редактирование, используя, при необходимости, клавиши Del,Backspace. Фиксация изменений выполняется клавишейEnter.

Использование текста в формулах

С текстовыми значениями можно выполнять математические операции, если текстовые значения содержат только следующие символы:

Цифры от 0 до 9 , + — е Е /

Еще можно использовать пять символов числового форматирования:

$ % ( ) пробел

При этом текст должен быть заключен в двойные кавычки.

Неправильно: =$55+$33

Правильно: =»$55″+$»33″

При выполнении вычислений Excelпреобразует числовой текст в числовые значения, так результатом вышеуказанной формулы будет значение 88.

Для объединения текстовых значений служит текстовый оператор & (амперсанд). Например, если ячейка А1 содержит текстовое значение «Иван», а ячейка А2 — «Петров», то введя в ячейку А3 следующую формулу =А1&А2, получим «ИванПетров».

Для вставки пробела между именем и фамилией надо написать так =А1&» «&А2.

Амперсанд можно использовать для объединения ячеек с разными типами данных. Так, если в ячейке А1 находится число 10, а в ячейке А2 — текст «мешков», то в результате действия формулы =А1&А2, мы получим «10мешков». Причем результатом такого объединения будет текстовое значение.

«Ввод данных в Excel || Эксель || имена ячеек Excel»

top

— Функции Excel- знакомство

— Функции

— Автосумма

— Использование заголовков в формулах

Функции

Функция Excel— это заранее определенная формула, которая работает с одним или несколькими значениями и возвращает результат.

Наиболее распространенные функции Excelявляются краткой записью часто используемых формул.

Например функция =СУММ(А1:А4)аналогична записи=А1+А2+А3+А4.

А некоторые функции выполняют очень сложные вычисления.

Каждая функция состоит из именииаргумента.

В предыдущем случае СУММ— этоимяфункции, аА1:А4аргумент. Аргумент заключается в круглые скобки.

Автосумма

Т.к. функция суммы используется наиболее часто, то на панель инструментов «Стандартная» вынесена кнопка «Автосумма».

Введите в ячейки А1, А2, А3 произвольные числа. Активизируйте ячейку А4 и нажмите кнопку автосуммы. Результат показан ниже.

Нажмите клавишу ввода. В ячейку А4 будет вставлена формула суммы ячеек А1..А3. Кнопка автосуммы снабжена выпадающим списком, из которого можно выбрать другую формулу для ячейки.

Для выбора функции служит кнопка «Вставка функции» в строке формул. При ее нажатии появляется следующее окно.

Если точно неизвестна функция, которую надо применить в данный момент, то в окне диалога «Поиск функции» можно произвести поиск.

В выпадающем списке «Категория» надо выбрать подходящую категорию для использования функции. Саму функцию выбирают в нижнем окне «Выберите функцию».

Если формула очень громоздкая, то можно включить в текст формулы пробелы или разрывы строк. Это никак не влияет на результаты вычислений. Для разрыва строки надо нажать комбинацию клавиш Alt+Enter.

Использование заголовков в формулах

Можно использовать в формулах вместо ссылок на ячейки таблицы заголовки таблицы. Постройте следующий пример.

По умолчанию MicrosoftExcelне распознает заголовки в формулах. Чтобы использовать заголовки в формулах, выберите команду Параметры в меню Сервис. На вкладке Вычисления в группе Параметры книги установите флажок Допускать названия диапазонов.

При обычной записи формула в ячейке В6 выглядела бы так: =СУММ(В2:В4).

При использовании заголовков формула будет выглядеть так: =СУММ(Кв 1).

— Необходимо знать следующее:

— Если формула содержит заголовок столбца/строки, в котором она находится, то Excelсчитает, что вы хотите использовать диапазон ячеек, расположенных ниже заголовка столбца таблицы (или справа от заголовка строки);

— Если формула содержит заголовок столбца/строки, отличного от того, в котором она находится, Excelсчитает, что вы хотите использовать ячейку на пересечении столбца/строки с таким заголовком и строки/столбца, где расположена формула.

— При использовании заголовков можно указать любую ячейку таблицы с помощью — пересечения диапазонов. Например, для ссылки на ячейку С3 в нашем примере можно использовать формулу =Строка2 Кв 2. Обратите внимание на пробел между заголовками строки и столбца.

— Формулы, содержащие заголовки, можно копировать и вставлять, при этом Excelавтоматически настраивает их на нужные столбцы и строки. Если будет произведена попытка скопировать формулу в неподходящее место, тоExcelсообщит об этом, а в ячейке выведет значение ИМЯ?. При смене названий заголовков, аналогичные изменения происходят и в формулах.

«Ввод данных в Excel || Эксель || имена ячеек Excel»

top

Имена ячеек и диапазонов в Excel

— Имена в формулах

— Присвоение имен в поле имени

— Правила присваивания имен ячейкам и диапазонам

Ячейкам Excelи диапазонам ячеек можно присваивать имена и затем использовать их в формулах. Если формулы, содержащие заголовки, можно применять только в том же листе, где находится таблица, то, используя имена диапазонов, можно ссылаться на ячейки таблицы в любом месте любой книги.

Имена в формулах

Имя ячейки или диапазона можно использовать в формуле. Пусть у нас в ячейке А3 записана формула А1+А2. Если присвоить ячейке А1 имя «Базис», а ячейке А2 — «Надстройка», то запись Базис+Надстройка возвратит то же самое значение, что и предыдущая формула.

Присвоение имен в поле имени

Для присвоения имени ячейке (диапазону ячеек) надо выделить соответствующий элемент, а затем в поле имени ввести наименование, при этом нельзя использовать пробелы.

Если выделенной ячейке или диапазону было дано имя, то в поле имени выводится именно оно, а не ссылка на ячейку. Если имя определено для диапазона ячеек, оно появится в поле имени только при выделении всего диапазона.

Если нужно перейти к именованной ячейке или диапазону, щелкните на стрелке рядом с полем имени и выберите в раскрывающемся списке имя ячейки или диапазона.

Более гибкие возможности присвоения имен ячеек и их диапазонов, а также заголовков, дает команда «Имя» из меню «Вставка».

Правила присваивания имен ячейкам и диапазонам

— Имя должно начинаться с буквы, обратной косой черты (\) или символа подчеркивания (_).

— В имени можно использовать только буквы, цифры, обратную косую черту и символ подчеркивания.

— Нельзя использовать имена, которые могут трактоваться как ссылки на ячейки (А1, С4).

— В качестве имен могут использоваться одиночные буквы за исключением букв R,C.

— Пробелы необходимо заменять символом подчеркивания.

«Функции Excel|| Эксель || МассивыExcel»

top

Массивы Excel

— Использование массивов

— Двумерные массивы

— Правила для формул массива

Массивы в Excelиспользуют для создания формул, которые возвращают некоторое множество результатов или оперируют множеством значений.

Использование массивов

Разберем несколько примеров для того, чтобы лучше понять массивы.

Давайте вычислим, используя массивы, сумму значений в строках для каждого столбца. Для этого сделайте следующее:

— Введите в диапазон A1:D2 числовые значения.

— Выделите диапазонA3:D3.

— В строке формул введите =A1:D1+A2:D2.

— Нажмите комбинацию клавиш Ctrl+Shift+Enter.

Ячейки A3:D3 образуют диапазон массива, а формула массива хранится в каждой ячейке этого диапазона. Массив аргументов — это ссылки на диапазоныA1:D1 иA2:D2

Двумерные массивы

В предыдущем примере формулы массива размещались в горизонтальном одномерном массива. Можно создавать массивы, которые содержат несколько строк и столбцов. Такие массивы называются двумерными.

Правила для формул массива

— Перед вводом формулы массива надо выделить ячейку или диапазон ячеек, который будет содержать результаты. Если формула возвращает несколько значений, необходимо выделить диапазон такого же размера и формы, как диапазон с исходными данными.

— Нажмите клавиши Ctrl+Shift+Enterдля фиксации ввода формулы массива. При этомExcelзаключит формулу в фигурные скобки в строке формул. НЕ ВВОДИТЕ ФИГУРНЫЕ СКОБКИ ВРУЧНУЮ!

-В диапазоне нельзя изменять, очищать или перемещать отдельные ячейки, а также вставлять или удалять ячейки. Все ячейки в диапазоне массива надо рассматривать как единое целое и редактировать все их сразу.

— Для изменения или очистки массива надо выделить весь массив и активизировать строку формул. После изменения формулы надо нажать комбинацию клавиш Ctrl+Shift+Enter.

— Чтобы переместить содержимое диапазона массива, надо выделить весь массив и в меню «Правка» выбрать команду «Вырезать». Затем выделите новый диапазон и в меню «Правка» выберите команду «Вставить».

— Вырезать, очищать или редактировать часть массива не разрешается, но можно назначать разные форматы отдельным ячейкам в массиве.

«Ячейки и диапазоны Excel|| Эксель || Форматирование вExcel»

top

Назначение и удаление форматов в Excel

— Назначение формата

— Удаление формата

— Форматирование с помощью панелей инструментов

— Форматирование отдельных символов

— Применение автоформата

Форматирование в Excelприменяется для облегчения восприятия данных, что играет немаловажную роль в производительности труда.

Назначение формата

— Выделите ячейку (диапазон ячеек).

— Выберите команду «Формат»-«Ячейки» (Ctrl+1).

— В появившемся окне диалога (подробно окно будет рассмотрено позже) введите нужные параметры форматирования.

— Нажмите кнопку «Ок»

Форматированная ячейка сохраняет свой формат, пока к ней не будет применен новый формат или не удален старый. При вводе значения в ячейку к нему применяется уже используемый в ячейке формат.

Удаление формата

— Выделите ячейку (диапазон ячеек).

— Выберите команду «Правка»-«Очистить»-«Форматы».

— Для удаления значений в ячейках надо выбрать команду «Все» подменю «Очистить».

Следует учитывать, что при копировании ячейки наряду с ее содержимым копируется и формат ячейки. Таким образом, можно сберечь время, форматируя исходную ячейку до использования команд копирования и вставки.

Форматирование с помощью панелей инструментов

Наиболее часто используемые команды форматирования вынесены на панель инструментов «Форматирование». Чтобы применить формат с помощью кнопки панели инструментов, выделите ячейку или диапазон ячеек и затем нажмите кнопку мышью. Для удаления формата надо нажать кнопку повторно.

Для быстрого копирования форматов из выделенных ячеек в другие ячейки можно использовать кнопку «Формат по образцу» панели «Форматирование».

Форматирование отдельных символов

Форматирование можно применять к отдельным символам текстового значения в ячейке так же, как и ко всей ячейке. Для этого выделите нужные символы и затем в меню «Формат» выберите команду «Ячейки». Установите нужные атрибуты и нажмите кнопку «Ок». Нажмите клавишу Enter, чтобы увидеть результаты своего труда.

Применение автоформата

Автоматические форматы Excel- это заранее определенные сочетания числового формата, шрифта, выравнивания, границ, узора, ширины столбца и высоты строки.

Чтобы использовать автоформат, надо выполнить следующие действия:

— Введите нужные данные в таблицу.

— Выделите диапазон ячеек, которые необходимо форматировать.

— В меню «Формат» выберите команду «Автоформат». При этом откроется окно диалога.

— В окне диалога «Автоформат» нажмите кнопку «Параметры», чтобы отобразить область «Изменить».

— Выберите подходящий автоформат и нажмите кнопку «Ок».

— Выделите ячейку вне таблицы для снятия выделения с текущего блока, и вы увидите результаты форматирования.

«Массивы Excel|| Эксель || Форматирование чисел вExcel»

top

Форматирование чисел и текста в Excel

-Общий формат

-Числовые форматы

-Денежные форматы

-Финансовые форматы

-Процентные форматы

-Дробные форматы

-Экспоненциальные форматы

-Текстовый формат

-Дополнительные форматы

-Создание новых форматов

Окно диалога «Формат ячеек» (Ctrl+1) позволяет управлять отображением числовых значений и изменять вывод текста.

Перед открытием окна диалога выделяйте ячейку, содержащую число, которое надо форматировать. В этом случае всегда будет виден результат в поле «Образец». Не следует забывать о различии между хранимыми и отображаемыми значениями. На хранимые числовые или текстовые значения в ячейках форматы на действуют.

Общий формат

Любое введенное текстовое или числовое значение по умолчанию отображается в формате «Общий». При этом оно отображается точно так, как было введено в ячейку за исключением трех случаев:

-Длинные числовые значения отображаются в экспоненциальной форме записи или округляются.

-Формат не отображает незначащие нули (456,00 = 456).

-Десятичная дробь, введенная без числа слева от десятичной запятой, выводится с нулем (,23 = 0,23).

Числовые форматы

Этот формат позволяет выводить числовые значения в виде целых чисел или чисел с фиксированной запятой, а также выделять отрицательные числа с помощью цвета.

Денежные форматы

Эти форматы аналогичны числовым форматам за исключением того, что вместо разделителя групп разрядов они позволяют управлять выводом символа денежной единицы, который можно выбрать в списке «Обозначение».

Финансовые форматы

Финансовый формат в основном соответствует денежным форматам — можно вывести число с денежной единицей или без нее с заданным количеством десятичных знаков. Основное различие состоит в том, что финансовый формат выводит денежную единицу с выравниванием по левому краю, в то время как само число выравнивается по правому краю ячейки. В результате и денежная единица, и числа вертикально выравниваются в столбце.

Процентные форматы

Данный формат выводит числа в виде процентов. Десятичная запятая в форматируемом числе сдвигается на два знака вправо, а знак процента выводится в конце числа.

Дробные форматы

Данный формат выводит дробные значения как обычные, а не десятичные дроби. Эти форматы особенно полезны при воде биржевых цен или измерений.

Экспоненциальные форматы

Экспоненциальные форматы отображают числа в экспоненциальной записи. Данный формат очень удобно использовать для отображения и вывода очень малых или очень больших чисел.

Текстовый формат

Применение к ячейке текстового формата означает, что значение в этой ячейке должно трактоваться как текст, о чем свидетельствует выравнивание по левому краю ячейки.

Не беда, если числовое значение отформатирована как текст, т.к. Excel способен распознавать числовые значения. Ошибка будет, если в ячейке, имеющей текстовый формат, стоит формула. В этом случае формула рассматривается как простой текст, поэтому возможны ошибки.

Дополнительные форматы

Эта категория содержит два формата почтовых индексов, формат номера телефона и формат табельного номера. Эти форматы позволяют быстро вводить числа без вода специальных символов.

Создание новых форматов

Чтобы создать формат на базе существующего формата надо сделать следующее:

-Выделите ячейки, которые надо отформатировать.

-Нажмите комбинацию клавиш Ctrl+1 и на вкладке «Число» открывшегося окна диалога выберите категорию «Все форматы».

-В списке «Тип» выберите формат, который надо изменить и отредактируйте содержимое поля. При этом исходный формат сохранится без изменений, а новый формат добавится к списку «Тип».

«Форматирование в Excel || Эксель ||

top

77777777

Выравнивание содержимого ячеек Excel

-Выравнивание по левому краю, по центру и по правому краю

-Заполнение ячеек

-Перенос по словам и выравнивание по ширине

-Выравнивание по вертикали и ориентация текста

-Автоподбор размера символов

Вкладка «Выравнивание» окна диалога «Формат ячеек» контролирует расположение текста и чисел в ячейках. Эту вкладку можно также использовать для создания многострочных надписей, повторения ряда символов в одной или нескольких ячейках, изменения ориентации текста.

Выравнивание по левому краю, по центру и по правому краю

При выборе вариантов «По левому краю», «По центру» или «По правому краю» содержимое выделенных ячеек выравнивается соответственно по левому краю, по центру или по правому краю ячейки.

При выравнивании по левому краю вы можете изменять величину отступа, которая по умолчанию принимается равной нулю. При увеличении отступа на одну единицу значение в ячейке смещается на ширину одного символа вправо, которая приблизительно равна ширине прописной буквы Х в стиле «Обычный».

Заполнение ячеек

Формат «С заполнением» повторяет введенное в ячейке значение, чтобы заполнить всю ширину столбца. Например, в листе, показанном на рисунке выше, ячейка А7 повторяет слово «Заполнение». Хотя кажется, что диапазон ячеек А7-А8 содержит множество слов «Заполнение», строка формул говорит о том, что в действительности есть только одно слово. Подобно всем другим форматам, формат «С заполнением» воздействует только на внешний вид, а не на хранимое содержимое ячейки. Excel повторяет символы вдоль всего диапазона без промежутков между ячейками.

Может показаться, что повторяющиеся символы так же просто ввести с клавиатуры, как и с помощью заполнения. Однако формат «С заполнением» дает два важных преимущества. Во-первых, если вы настраиваете ширину столбца, Excel должным образом увеличивает или уменьшает число символов в ячейке. Во-вторых, можно повторить символ или символы сразу в нескольких соседних ячейках.

Поскольку данный формат воздействует на числовые значения так же, как и на текст, то число может выглядеть совсем не так, как нужно. Например, если вы примените такой формат к ячейке шириной в 10 символов, которая содержит число 8, в этой ячейке будет отображено 8888888888.

Перенос по словам и выравнивание по ширине

Если вы ввели надпись, которая слишком длинна для активной ячейки, Excel расширяет надпись за пределы ячейки при условии, что соседние ячейки пусты. Если вы затем на вкладке «Выравнивание» установите флажок «Переносить по словам», Excel выведет эту надпись полностью в пределах одной ячейки. Для этого программа увеличит высоту строки, в которой находится ячейка, и затем разместит текст на дополнительных строках внутри ячейки.

При применении формата горизонтального выравнивания «По ширине» текст в активной ячейке переносится по словам на дополнительные строки внутри ячейки и выравнивается по левому и правому краям с автоматической настройкой высоты строки.

Если вы создаете многострочную надпись и впоследствии снимаете флажок «Переносить по словам» или применяете другой формат горизонтального выравнивания, то Excel восстанавливает первоначальную высоту строки.

Формат вертикального выравнивания «По высоте» делает, в сущности, то же самое, что и его аналог «По ширине», за исключением того, что он выравнивает значение ячейки относительно ее верхнего и нижнего краев, а не боковых сторон.

Выравнивание по вертикали и ориентация текста

Excel предоставляет четыре формата выравнивания текста по вертикали: по верхнему краю, по центру, по нижнему краю, по высоте.

Область «Ориентация» позволяет размещать содержимое ячеек вертикально сверху вниз или наклонно под углом до 90 градусов по часовой или против часовой стрелки. Excel автоматически настраивает высоту строки при вертикальной ориентации в том случае, если вы сами ранее или впоследствии не установите высоту строки вручную.

Автоподбор размера символов

Флажок «Автоподбор ширины» уменьшает размер символов в выделенной ячейке так, чтобы ее содержимое полностью помещалось в столбце. Это может быть полезно при работе с листом, в котором настройка ширины столбца по длинному значению имеет нежелательный эффект для остальных данных, или в том случае. Когда использование вертикального или наклонного текста, переноса по словам является неприемлемым решением. На рисунке, представленном ниже, в ячейки А1 и А2 введен одинаковый текст, но для ячейки А2 установлен флажок «Автоподбор ширины». При изменении ширины столбца будет соответственно уменьшаться или увеличиваться размер символов в ячейке А2. Однако при этом сохраняется размер шрифта, назначенный ячейке, и при увеличении ширины столбца после достижения определенной величины настройка размера символов производиться не будет.

Следует сказать следующее, что, хотя данный формат является хорошим способом решения некоторых проблем, но надо иметь в виду, что размер символов может быть сколь угодно малым. Если столбец узкий, а значение достаточно длинное, то после применения этого формата содержимое ячейки может стать нечитабельным.

«Пользовательский формат || Эксель || Шрифт в Excel»

top

777777

Использование границ и заливки ячеек Excel

-Использование границ

-Применение цвета и узоров

-Использование заливки

Использование границ

Границы и заливка ячеек могут быть хорошим средством для оформления различных областей рабочего листа или привлечения внимания к важным ячейкам.

Для выбора типа линии щелкните на любом из тринадцати типов линии границы, включающих четыре сплошных линии разной толщины, двойную линию и восемь видов пунктирных линий.

По умолчанию цвет линии границы является черным, если на вкладке «Вид» окна диалога «Параметры» в поле «Цвет» установлено значение «Авто». Чтобы выбрать цвет, отличный от черного, щелкните на стрелке справа от поля «Цвет». Раскроется текущая 56-цветная палитра, в которой можно использовать один из имеющихся цветов или определить новый. Обратите внимание, что для выбора цвета границы нужно использовать список «Цвет» на вкладке «Граница». Если вы попытаетесь это сделать с помощью панели инструментов форматирования, то измените цвет текста в ячейке, а не цвет границы.

После выбора типа и цвета линии нужно указать положение границы. При нажатии кнопки «Внешние» в области «Все» граница размещается по периметру текущего выделения, будь то одна ячейка или блок ячеек. Чтобы удалить все границы, имеющиеся в выделении, нажмите кнопку «Нет». Область просмотра позволяет контролировать размещение границ. При первом открытии окна диалога для единственной выделенной ячейки эта область содержит только небольшие маркеры, обозначающие углы ячейки. Чтобы разместить границу, щелкните на области просмотра в том месте, где должна находиться граница, или нажмите соответствующую кнопку рядом с этой областью. Если в рабочем листе выделено несколько ячеек, в этом случае на вкладке «Граница» становится доступной кнопка «Внутренние», с помощью которой можно добавить границы между выделенными ячейками. Кроме того, в области просмотра появляются дополнительные маркеры на сторонах выделения, указывающие, где будут проходить внутренние границы.

Чтобы удалить размещенную границу, просто щелкните на ней в области просмотра. Если нужно изменить формат границы, выберите другой тип линии или цвет и щелкните на этой границе в области просмотра. Если хотите начать размещение границ заново, нажмите кнопку «Нет» в области «Все».

Можно применять к выделенным ячейкам несколько типов границ одновременно.

Можно применять комбинации границ, используя кнопку «Границы» на панели инструментов «Форматирование». После щелчка на маленькой стрелке рядом с этой кнопкой Excelвыведет палитру границ, в которой можно выбирать тип границы.

Палитра состоит из 12 вариантов границ, в том числе комбинации различных типов, например одиночная верхняя граница и двойная нижняя. Первый вариант в палитре удаляет все форматы границ в выделенной ячейке или диапазоне. Другие варианты показывают в миниатюре расположение границы или комбинации границ.

В качестве тренировки постарайтесь сделать небольшой пример, приведенный ниже. Для разрыва строки необходимо нажимать клавишу Enterпри нажатойAlt.

Применение цвета и узоров

Вкладка «Вид» окна диалога «Формат ячеек» используется для применения цвета и узоров к выделенным ячейкам. Эта вкладка содержит текущую палитру и раскрывающуюся палитру узоров.

Палитра «Цвет» на вкладке «Вид» позволяет задать фон для выделенных ячеек. Если вы выберете цвет в палитре «Цвет», не выбирая узора, то заданный цветовой фон появится в выделенных ячейках. Если выбрать цвет в палитре «Цвет», а затем — узор в раскрывающейся палитре «Узор», этот узор накладывается на цвет фона. Цвета в раскрывающейся палитре «Узор» контролируют цвет самого узора.

Использование заливки

Различные варианты заливки ячеек, предоставляемые вкладкой «Вид», можно использовать для наглядного оформления рабочего листа. Например, заливку можно применять для выделения итоговых данных или для привлечения внимания к ячейкам рабочего листа, предназначенным для ввода данных. Для облегчения просмотра числовых данных по строкам можно использовать, так называемую «полосовую заливку», когда чередуются строки различного цвета.

В качестве фона ячеек следует выбирать такой цвет, который позволяет легко читать текст и числовые значения, выведенные используемым по умолчанию черным шрифтом.

Excelпозволяет добавлять к рабочему листу фоновое изображение. Для этого выберите в меню «Формат» команду «Лист»-«Подложка». Появится окно диалога, позволяющее открыть графический файл, хранящийся на диске. Затем это графическое изображение используется в качестве фона текущего рабочего листа подобно водяным знакам на листе бумаги. Графическое изображение при необходимости повторяется до заполнения всего рабочего листа. Вы можете отключить вывод линий сетки в листе, для этого в меню «Сервис» надо выбрать команду «Параметры» и на вкладке «Вид» и снять флажок «Сетка». Ячейки, которым назначен цвет или узор, выводят только цвет или узор, а не графическое фоновое изображение.

«Шрифт Excel|| Эксель || Объединение ячеек»

77777

Условное форматирование и объединение ячеек

— Условное форматирование

— Объединение ячеек

— Условное форматирование

Условное форматирование позволяет применять форматы к конкретным ячейкам, которые остаются «спящими», пока значения в этих ячейках не достигнут некоторых контрольных значений.

Выделите ячейки, предназначенные для форматирования, затем в меню «Формат» выберите команду «Условное форматирование», перед вами появится окно диалога, представленное ниже.

Первое поле со списком в окне диалога «Условное форматирование» позволяет выбрать, к чему должно применяться условие: к значению или самой формуле. Обычно выбирается параметр «Значение», при котором применение формата зависит от значений выделенных ячеек. Параметр «Формула» применяется в тех случаях, когда нужно задать условие, в котором используются данные из невыделенных ячеек, или надо создать сложное условие, включающее в себя несколько критериев. В этом случае во второе поле со списком следует ввести логическую формулу, принимающую значение ИСТИНА или ЛОЖЬ. Второе поле со списком служит для выбора оператора сравнения, используемого для задания условия форматирования. Третье поле используется для задания сравниваемого значения. Если выбран оператор «Между» или «Вне», то в окне диалога появляется дополнительное четвертое поле. В этом случае в третьем и четвертом полях необходимо указать нижнее и верхнее значения.

После задания условия нажмите кнопку «Формат». Откроется окно диалога «Формат ячеек», в котором можно выбрать шрифт, границы и другие атрибуты формата, который должен применяться при выполнении заданного условия.

В приведенном ниже примере задан следующий формат: цвет шрифта — красный, шрифт — полужирный. Условие: если значение в ячейке превышает «100».

Иногда трудно определить, где было применено условное форматирование, Чтобы в текущем листе выделить все ячейки с условным форматированием, выберите команду «Перейти» в меню «Правка», нажмите кнопку «Выделить», затем установите переключатель «Условные форматы».

Чтобы удалить условие форматирования, выделите ячейку или диапазон и затем в меню «Формат» выберите команду «Условное форматирование». Укажите условия, которые хотите удалить, и нажмите «ОК».

Объединение ячеек

Сетка является очень важным конструктивным элементом оформления электронной таблицы. Иногда для достижения нужного эффекта бывает необходимо форматировать сетку специальным образом. Excelпозволяет объединять ячейки, что придает сетке новые возможности, которые можно использовать для создания более четких форм и отчетов.

При объединении ячеек образуется одна ячейка, размеры которой совпадают с размерами первоначального выделения. Объединенная ячейка получает адрес верхней левой ячейки исходного диапазона. Остальные исходные ячейки практически перестают существовать. Если в формуле встречается ссылка на такую ячейку, она рассматривается как пустая, и в зависимости от типа формулы ссылка может возвратить нулевое или ошибочное значение.

Чтобы объединить ячейки, надо выполнить следующее:

— выделить исходные ячейки;

— в меню «Формат» выбрать команду «Ячейки»;

— на вкладке «Выравнивание» окна диалога «Формат ячеек» установить флажок «Объединение ячеек»;

— нажать «ОК».

Если данной командой приходится пользоваться довольно часто, то гораздо удобнее «вытащить» ее на панель инструментов. Для этого надо выбрать меню «Сервис»-«Настройка…», в появившемся окне надо перейти на вкладку «Команды» и в правом окне выбрать категорию «Форматирование». В левом окне «Команды», используя полосу прокрутки, найти «Объединение ячеек» и перетащить данную иконку (используя левую кнопку мыши) на панель инструментов «Форматирование».

Объединение ячеек имеет ряд последствий, и самым наглядным является нарушение сетки — одного из основных атрибутов электронных таблиц. При этом следует учитывать некоторые нюансы:

— Если только одна ячейка в выделенном диапазоне является непустой, то при объединении ее содержимое переразмещается в объединенной ячейке. Так, например, при объединении ячеек диапазона А1:В5, где ячейка А2 является непустой, эта ячейка будет перенесена в объединенную ячейку А1;

— Если несколько ячеек в выделенном диапазоне содержат значения или формулы, то при объединении сохраняется только содержимое левой верхней ячейки, которое переразмещается в объединенной ячейке. Содержимое остальных ячеек удаляется. Если надо сохранить данные в этих ячейках, то перед объединением следует добавить их в левую верхнюю ячейку или переместить в другое место вне выделения;

— Если диапазон объединения содержит формулу, которая переразмещается в объединенной ячейке, то относительные ссылки в ней настраиваются автоматически;

— Объединенные ячейки Excelможно копировать, вырезать и вставлять, удалять и перетаскивать, как и обычные ячейки. После копирования или перемещения объединенной ячейки она занимает в новом месте такое же количество ячеек. На месте вырезанной или удаленной объединенной ячейки восстанавливается стандартная структура ячеек;

— При объединении ячеек все границы удаляются, за исключением внешней границы всего выделенного диапазона, а также границы, которая применена к любому краю выделения целиком.

«Границы и заливка || Эксель || Редактирование»

top

77777

Вырезание и вставка ячеек в Excel

Вырезание и вставка

Правила вырезания и вставки

Вставка вырезанных ячеек

Вырезание и вставка

Команды «Вырезать» и «Вставить» меню «Правка» можно использовать для перемещения значений и форматов из одного места в другое. В отличие от команд «Удалить» и «Очистить», которые удаляют ячейки или их содержимое, команда «Вырезать» размещает подвижную пунктирную рамку вокруг выделенных ячеек и помещает копию выделения в буфер обмена, который сохраняет данные для того, чтобы их можно было вставить в другое место.

После выделения диапазона, в который надо переместить вырезанные ячейки, команда «Вставить» помещает их в новое место, очищает содержимое ячеек внутри подвижной рамки и удаляет подвижную рамку.

При использовании команд «Вырезать» и «Вставить» для перемещения диапазона ячеек Excelочищает содержимое и форматы в вырезанном диапазоне и переносит их в диапазон вставки.

При этом Excelнастраивает все формулы вне вырезаемой области, которые ссылаются на эти ячейки.

Правила вырезания и вставки

— Выделенная вырезаемая область должна быть единым прямоугольным блоком ячеек;

— При использовании команды «Вырезать» вставка осуществляется только один раз. Для вставки выделенных данных в несколько мест надо использовать комбинацию команд «Копировать»-«Очистить»;

— Не обязательно выделять весь диапазон вставки перед использованием команды «Вставить». При выделении одной ячейки в качестве диапазона вставки Excelрасширяет область вставки в соответствии с размером и формой вырезаемой области. Выделенная ячейка считается левым верхним углом области вставки. Если выделяется всю область вставки, то необходимо убедиться, что выделенный диапазон имеет тот же размер, что и вырезаемая область;

— При использовании команды «Вставить» Excelзамещает содержимое и форматы во всех существующих ячейках в диапазоне вставки. Если вы не хотите потерять содержимое существующих ячеек, убедитесь, что для размещения всей вырезаемой области в рабочем листе имеется достаточно пустых ячеек снизу и справа от выделенной ячейки, которая окажется в верхнем левом углу области экрана.

Вставка вырезанных ячеек

При использовании команды «Вставить» Excelвставляет вырезаемые ячейки в выделенную область рабочего листа. Если выделенная область уже содержит данные, то они заменяются вставляемыми значениями.

В некоторых случаях можно вставить содержимое буфера обмена между ячейками вместо размещения его в существующих ячейках. Для этого следует использовать команду «Вырезать ячейки» меню «Вставка» вместо команды «Вставить» меню «Правка».

Команда «Вырезать ячейки» заменяет команду «Ячейки» и появляется только после удаления данных в буфер обмена.

Например, в приведенном ниже примере, изначально были вырезаны ячейки А5:А7 (команда «Вырезать» меню «Правка»); затем была сделана активной ячейка А1; затем выполнена команда «Вырезать ячейки» из меню «Вставка».

«Заполнение рядов || Эксель || Функции Excel»

top

Функции. Синтаксис функций Excel

Синтаксис функций

Использование аргументов

Типы аргументов

На занятии №4 мы уже делали первое знакомство с функциями Excel. Теперь пришло время более тщательно изучить этот мощный инструментарий электронных таблиц.

Функции Excel- это специальные, заранее созданные формулы, которые позволяют легко и быстро выполнять сложные вычисления. Их можно сравнить со специальными клавишами на калькуляторах, предназначенных для вычисления квадратных корней, логарифмов и проч.

Excelимеет несколько сотен встроенных функций, которые выполняют широкий спектр различных вычислений. Некоторые функции являются эквивалентами длинных математических формул, которые можно сделать самому. А некоторые функции в виде формул реализовать невозможно.

Синтаксис функций

Функции состоят из двух частей: имени функции и одного или нескольких аргументов. Имя функции, например СУММ, — описывает операцию, которую эта функция выполняет. Аргументы задают значения или ячейки, используемые функцией. В формуле, приведенной ниже: СУММ — имя функции; В1:В5 — аргумент. Данная формула суммирует числа в ячейках В1, В2, В3, В4, В5.

=СУММ(В1:В5)

Знак равенства в начале формулы означает, что введена именно формула, а не текст. Если знак равенства будет отсутствовать, то Excelвоспримет ввод просто как текст.

Аргумент функции заключен в круглые скобки. Открывающая скобка отмечает начало аргумента и ставится сразу после имени функции. В случае ввода пробела или другого символа между именем и открывающей скобкой в ячейке будет отображено ошибочное значение #ИМЯ? Некоторые функции не имеют аргументов. Даже в этом случае функция должна содержать круглые скобки:

=С5*ПИ()

Использование аргументов

При использовании в функции нескольких аргументов они отделяются один от другого точкой с запятой. Например, следующая формула указывает, что необходимо перемножить числа в ячейках А1, А3, А6:

=ПРОИЗВЕД(А1;А3;А6)

В функции можно использовать до 30 аргументов, если при этом общая длина формулы не превосходит 1024 символов. Однако любой аргумент может быть диапазоном, содержащим произвольное число ячеек листа. Например:

=СУММ(А2:А5;В4:В8)

Указанные в ссылке ячейки в свою очередь могут содержать формулы, которые ссылаются на другие ячейки или диапазоны. Используя аргументы, можно легко создавать длинные цепочки формул для выполнения сложных операций.

Типы аргументов

В приведенных ранее примерах все аргументы были ссылками на ячейки или диапазоны. Но в качестве аргументов можно также использовать числовые, текстовые и логические значения, имена диапазонов, массивы и ошибочные значения. Некоторые функции возвращают значения этих типов, и их в дальнейшем можно использовать в качестве аргументов в других функциях.

Числовые значения

Аргументы функции могут быть числовыми. Например, функция СУММ в следующей формуле суммирует числа 24, 987, 49:

=СУММ(24;987;49)

Текстовые значения

В качестве аргумента функции могут использоваться текстовые значения. Например:

=ТЕКСТ(ТДАТА();»Д МММ ГГГГ»)

В этой формуле второй аргумент функции ТЕКСТ является текстовым и задает шаблон для преобразования десятичного значения даты, возвращаемого функцией ТДАТА(NOW), в строку символов. Текстовый аргумент может быть строкой символов, заключенной в двойные кавычки, или ссылкой на ячейку, которая содержит текст.

Логические значения

Аргументы ряда функций могут принимать только логические значения ИСТИНА или ЛОЖЬ. Логическое выражение возвращает значение ИСТИНА или ЛОЖЬ в ячейку или формулу, содержащую это выражение. Например:

=ЕСЛИ(А1=ИСТИНА;»Повышение»;»Понижение»)&» цены»

Именованные ссылки

В качестве аргумента функции можно указать имя диапазона. Например, если диапазону ячеек А1:А5 присвоено имя «Дебет» (Вставка-Имя-Присвоить), то для вычисления суммы чисел в ячейках с А1 по А5 можно использовать формулу

=СУММ(Дебет)

Использование различных типов аргументов

В одной функции можно использовать аргументы различных типов. Например:

=СРЗНАЧ(Дебет;С5;2*8)

«Вставка ячеек || Эксель || Ввод функций Excel»

top

Ввод функций в рабочем листе Excel

Можно вводить функции в рабочем листе прямо с клавиатуры или с помощью команды «Функция» меню «Вставка». При вводе функции с клавиатуры лучше использовать строчные буквы. Когда ввод функции закончен, Excelизменит буквы в имени функции на прописные, если оно было введено правильно. Если буквы не изменяются, значит, имя функции введено неверно.

Если вы выделите ячейку и выберите в меню «Вставка» команду «Функция», Excelвыведет окно диалога «Мастер функций». Немного быстрее можно этого добиться, нажав клавишу со значком функции в строке формул.

Открыть это окно можно также с помощью кнопки «Вставка функции» на стандартной панели инструментов.

В этом окне сначала выберите категорию в списке «Категория» и затем в алфавитном списке «Функция» укажите нужную функцию.

Excelвведет знак равенства, имя функции и пару круглых скобок. ЗатемExcelоткроет второе окно диалога мастера функций.

Второе окно диалога мастера функций содержит по одному полю для каждого аргумента выбранной функции. Если функция имеет переменное число аргументов, это окно диалога при воде дополнительных аргументов расширяется. Описание аргумента, поле которого содержит точку вставки, выводится в нижней части окна диалога.

Справа от каждого поля аргумента отображается его текущее значение. Это очень удобно, когда вы используете ссылки или имена. Текущее значение функции отображается внизу окна диалога.

Нажмите кнопку «ОК» и созданная функция появится в строке формул.

«Синтаксис функций || Эксель || Математические функции»

top

Математические функции Excel

Здесь рассмотрены наиболее часто используемые математические функции Excel(краткая справка). Дополнительную информацию о функциях можно найти в окне диалога мастера функций, а также в справочной системеExcel. Кроме того, множество математических функций включено в надстройку «Пакет анализа».

Функция СУММ (SUM)

Функции ОКРУГЛ, ОКРУГЛВНИЗ, ОКРУГЛВВЕРХ

Функции ЧЁТН и НЕЧЁТ

Функции ОКРВНИЗ, ОКРВВЕРХ

Функции ЦЕЛОЕ и ОТБР

Функции СЛЧИС и СЛУЧМЕЖДУ

Функция ПРОИЗВЕД

Функция ОСТАТ

Функция КОРЕНЬ

Функция ЧИСЛОКОМБ

Функция ЕЧИСЛО

Функция LOG

Функция LN

Функция EXP

Функция ПИ

Функция РАДИАНЫ и ГРАДУСЫ

Функция SIN

Функция COS

Функция TAN

Функция СУММ (SUM)

Функция СУММ (SUM) суммирует множество чисел. Эта функция имеет следующий синтаксис:

=СУММ(числа)

Аргумент числа может включать до 30 элементов, каждый из которых может быть числом, формулой, диапазоном или ссылкой на ячейку, содержащую или возвращающую числовое значение. Функция СУММ игнорирует аргументы, которые ссылаются на пустые ячейки, текстовые или логические значения. Аргументы не обязательно должны образовывать непрерывные диапазоны ячеек. Например, чтобы получить сумму чисел в ячейках А2, В10 и в ячейках от С5 до К12, введите каждую ссылку как отдельный аргумент:

=СУММ(А2;В10;С5:К12)

Функции ОКРУГЛ, ОКРУГЛВНИЗ, ОКРУГЛВВЕРХ

Функция ОКРУГЛ (ROUND) округляет число, задаваемое ее аргументом, до указанного количества десятичных разрядов и имеет следующий синтаксис:

=ОКРУГЛ(число;количество_цифр)

Аргумент число может быть числом, ссылкой на ячейку, в которой содержится число, или формулой, возвращающей числовое значение. Аргумент количство_цифр, который может быть любым положительным или отрицательным целым числом, определяет, сколько цифр будет округляться. Задание отрицательного аргумента количество_цифр округляет до указанного количества разрядов слева от десятичной запятой, а задание аргумента количество_цифр равным 0 округляет до ближайшего целого числа. Excelцифры, которые меньше 5, с недостатком (вниз), а цифры, которые больше или равны 5, с избытком (вверх).

Функции ОКРУГЛВНИЗ (ROUNDDOWN) и ОКРУГЛВВЕРХ (ROUNDUP) имеют такой же синтаксис, как и функция ОКРУГЛ. Они округляют значения вниз (с недостатком) или вверх (с избытком).

Функции ЧЁТН и НЕЧЁТ

Для выполнения операций округления можно использовать функции ЧЁТН (EVEN) и НЕЧЁТ (ODD). Функция ЧЁТН округляет число вверх до ближайшего четного целого числа. Функция НЕЧЁТ округляет число вверх до ближайшего нечетного целого числа. Отрицательные числа округляются не вверх, а вниз. Функции имеют следующий синтаксис:

=ЧЁТН(число)

=НЕЧЁТ(число)

Функции ОКРВНИЗ, ОКРВВЕРХ

Функции ОКРВНИЗ (FLOOR) и ОКРВВЕРХ (CEILING) тоже можно использовать для выполнения операций округления. Функция ОКРВНИЗ округляет число вниз до ближайшего кратного для заданного множителя, а функция ОКРВВЕРХ округляет число вверх до ближайшего кратного для заданного множителя. Эти функции имеют следующий синтаксис:

=ОКРВНИЗ(число;множитель)

=ОКРВВЕРХ(число;множитель)

Значения число и множитель должны быть числовыми и иметь один и тот же знак. Если они имеют различные знаки, то будет выдана ошибка.

Функции ЦЕЛОЕ и ОТБР

Функция ЦЕЛОЕ (INT) округляет число вниз до ближайшего целого и имеет следующий синтаксис:

=ЦЕЛОЕ(число)

Аргумент — число — это число, для которого надо найти следующее наименьшее целое число.

Рассмотрим формулу:

=ЦЕЛОЕ(10,0001)

Эта формула возвратит значение 10, как и следующая:

=ЦЕЛОЕ(10,999)

Функция ОТБР (TRUNC) отбрасывает все цифры справа от десятичной запятой независимо от знака числа. Необязательный аргумент количество_цифр задает позицию, после которой производится усечение. Функция имеет следующий синтаксис:

=ОТБР(число;количество_цифр)

Если второй аргумент опущен, он принимается равным нулю. Следующая формула возвращает значение 25:

=ОТБР(25,490)

Функции ОКРУГЛ, ЦЕЛОЕ и ОТБР удаляют ненужные десятичные знаки, но работают они различно. Функция ОКРУГЛ округляет вверх или вниз до заданного числа десятичных знаков. Функция ЦЕЛОЕ округляет вниз до ближайшего целого числа, а функция ОТБР отбрасывает десятичные разряды без округления. Основное различие между функциями ЦЕЛОЕ и ОТБР проявляется в обращении с отрицательными значениями. Если вы используете значение -10,900009 в функции ЦЕЛОЕ, результат оказывается равен -11, но при использовании этого же значения в функции ОТБР результат будет равен -10.

Функции СЛЧИС и СЛУЧМЕЖДУ

Функция СЛЧИС (RAND) генерирует случайные числа, равномерно распределенные между 0 и 1, и имеет следующий синтаксис:

=СЛЧИС()

Функция СЛЧИС является одной из функций EXCEL, которые не имеют аргументов. Как и для всех функций, у которых отсутствуют аргументы, после имени функции необходимо вводить круглые скобки.

Значение функции СЛЧИС изменяется при каждом пересчете листа. Если установлено автоматическое обновление вычислений, значение функции СЛЧИС изменяется каждый раз при воде данных в этом листе.

Функция СЛУЧМЕЖДУ (RANDBETWEEN), которая доступна, если установлена надстройка «Пакет анализа», предоставляет больше возможностей, чем СЛЧИС. Для функции СЛУЧМЕЖДУ можно задать интервал генерируемых случайных целочисленных значений.

Синтаксис функции:

=СЛУЧМЕЖДУ(начало;конец)

Аргумент начало задает наименьшее число, которое может возвратить любое целое число от 111 до 529 (включая и оба эти значения):

=СЛУЧМЕЖДУ(111;529)

Функция ПРОИЗВЕД

Функция ПРОИЗВЕД (PRODUCT) перемножает все числа, задаваемые ее аргументами, и имеет следующий синтаксис:

=ПРОИЗВЕД(число1;число2…)

Эта функция может иметь до 30 аргументов. Excelигнорирует любые пустые ячейки, текстовые и логические значения.

Функция ОСТАТ

Функция ОСТАТ (MOD) возвращает остаток от деления и имеет следующий синтаксис:

=ОСТАТ(число;делитель)

Значение функции ОСТАТ — это остаток, получаемый при делении аргумента число на делитель. Например, следующая функция возвратит значение 1, то есть остаток, получаемый при делении 19 на 14:

=ОСТАТ(19;14)

Если число меньше чем делитель, то значение функции равно аргументу число. Например, следующая функция возвратит число 25:

=ОСТАТ(25;40)

Если число точно делится на делитель, функция возвращает 0. Если делитель равен 0, функция ОСТАТ возвращает ошибочное значение.

Функция КОРЕНЬ

Функция КОРЕНЬ (SQRT) возвращает положительный квадратный корень из числа и имеет следующий синтаксис:

=КОРЕНЬ(число)

Аргумент число должен быть положительным числом. Например, следующая функция возвращает значение 4:

КОРЕНЬ(16)

Если число отрицательное, КОРЕНЬ возвращает ошибочное значение.

Функция ЧИСЛОКОМБ

Функция ЧИСЛОКОМБ (COMBIN) определяет количество возможных комбинаций или групп для заданного числа элементов. Эта функция имеет следующий синтаксис:

=ЧИСЛОКОМБ(число;число_выбранных)

Аргумент число — это общее количество элементов, а число_выбранных — это количество элементов в каждой комбинации. Например, для определения количества команд с 5 игроками, которые могут быть образованы из 10 игроков, используется формула:

=ЧИСЛОКОМБ(10;5)

Результат будет равен 252. Т.е., может быть образовано 252 команды.

Функция ЕЧИСЛО

Функция ЕЧИСЛО (ISNUMBER) определяет, является ли значение числом, и имеет следующий синтаксис:

=ЕЧИСЛО(значение)

Пусть вы хотите узнать, является ли значение в ячейке А1 числом. Следующая формула возвращает значение ИСТИНА, если ячейка А1 содержит число или формулу, возвращающую число; в противном случае она возвращает ЛОЖЬ:

=ЕЧИСЛО(А1)

Функция LOG

Функция LOGвозвращает логарифм положительного числа по заданному основанию. Синтаксис:

=LOG(число;основание)

Если аргумент основание не указан, то Excelпримет его равным 10.

Функция LN

Функция LNвозвращает натуральный логарифм положительного числа, указанного в качестве аргумента. Эта функция имеет следующий синтаксис:

=LN(число)

Функция EXP

Функция EXPвычисляет значение константыe, возведенной в заданную степень. Эта функция имеет следующий синтаксис:

EXP(число)

Функция EXPявляется обратной по отношению кLN. Например, пусть ячейка А2 содержит формулу:

=LN(10)

Тогда следующая формула возвращает значение 10:

=EXP(А2)

Функция ПИ

Функция ПИ (PI) возвращает значение константы пи с точностью до 14 десятичных знаков. Синтаксис:

=ПИ()

Функция РАДИАНЫ и ГРАДУСЫ

Тригонометрические функции используют углы, выраженные в радианах, а не в градусах. Измерение углов в радианах основывается на константе пи и при этом 180 градусов равны пи радиан. Excelпредоставляет две функции, РАДИАНЫ (RADIANS) и ГРАДУСЫ (DEGREES), чтобы облегчить работу с тригонометрическими функциями.

Вы можете преобразовать радианы в градусы, используя функцию ГРАДУСЫ. Синтаксис:

=ГРАДУСЫ(угол)

Здесь — угол — это число, представляющее собой угол, измеренный в радианах. Для преобразования градусов в радианы используется функция РАДИАНЫ, которая имеет следующий синтаксис:

=РАДИАНЫ(угол)

Здесь — угол — это число, представляющее собой угол, измеренный в градусах. Например, следующая формула возвращает значение 180:

=ГРАДУСЫ(3,14159)

В то же время следующая формула возвращает значение 3,14159:

=РАДИАНЫ(180)

Функция SIN

Функция SINвозвращает синус угла и имеет следующий синтаксис:

=SIN(число)

Здесь число — угол в радианах.

Функция COS

Функция COSвозвращает косинус угла и имеет следующий синтаксис:

=COS(число)

Здесь число — угол в радианах.

Функция TAN

Функция TANвозвращает тангенс угла и имеет следующий синтаксис:

=TAN(число)

Здесь число — угол в радианах.

«Ввод функций || Эксель || Текстовые функции»

top

Текстовые функции Excel

Здесь рассмотрены наиболее часто используемые текстовые функции Excel(краткая справка). Дополнительную информацию о функциях можно найти в окне диалога мастера функций, а также в справочной системеExcel.

Функция ТЕКСТ

Функция РУБЛЬ

Функция ДЛСТР

Функция СИМВОЛ и КОДСИМВ

Функции СЖПРОБЕЛЫ и ПЕЧСИМВ

Функция СОВПАД

Функции ПРОПИСН, СТРОЧН и ПРОПНАЧ

Функции ЕТЕКСТ и ЕНЕТЕКСТ

Текстовые функции преобразуют числовые текстовые значения в числа и числовые значения в строки символов (текстовые строки), а также позволяют выполнять над строками символов различные операции.

Функция ТЕКСТ

Функция ТЕКСТ (TEXT) преобразует число в текстовую строку с заданным форматом. Синтаксис:

=ТЕКСТ(значение;формат)

Аргумент значение может быть любым числом, формулой или ссылкой на ячейку. Аргумент формат определяет, в каком виде отображается возвращаемая строка. Для задания необходимого формата можно использовать любой из символов форматирования за исключением звездочки. Использование формата Общий не допускается. Например, следующая формула возвращает текстовую строку 25,25:

=ТЕКСТ(101/4;»0,00″)

Функция РУБЛЬ

Функция РУБЛЬ (DOLLAR) преобразует число в строку. Однако РУБЛЬ возвращает строку в денежном формате с заданным числом десятичных знаков. Синтаксис:

=РУБЛЬ(число;число_знаков)

При этом Excelпри необходимости округляет число. Если аргумент число_знаков опущен,Excelиспользует два десятичных знака, а если значение этого аргумента отрицательное, то возвращаемое значение округляется слева от десятичной запятой.

Функция ДЛСТР

Функция ДЛСТР (LEN) возвращает количество символов в текстовой строке и имеет следующий синтаксис:

=ДЛСТР(текст)

Аргумент текст должен быть строкой символов, заключенной в двойные кавычки, или ссылкой на ячейку. Например, следующая формула возвращает значение 6:

=ДЛСТР(«голова»)

Функция ДЛСТР возвращает длину отображаемого текста или значения, а не хранимого значения ячейки. Кроме того, она игнорирует незначащие нули.

Функция СИМВОЛ и КОДСИМВ

Любой компьютер для представления символов использует числовые коды. Наиболее распространенной системой кодировки символов является ASCII. В этой системе цифры, буквы и другие символы представлены числами от 0 до 127 (255). Функции СИМВОЛ (CHAR) и КОДСИМВ (CODE) как раз и имеют дело с кодамиASCII. Функция СИМВОЛ возвращает символ, который соответствует заданному числовому кодуASCII, а функция КОДСИМВ возвращает кодASCIIдля первого символа ее аргумента. Синтаксис функций:

=СИМВОЛ(число)

=КОДСИМВ(текст)

Если в качестве аргумента текст вводится символ, обязательно надо заключить его в двойные кавычки: в противном случае Excelвозвратит ошибочное значение.

Функции СЖПРОБЕЛЫ и ПЕЧСИМВ

Часто начальные и конечные пробелы не позволяют правильно отсортировать значения в рабочем листе или базе данных. Если вы используете текстовые функции для работы с текстами рабочего листа, лишние пробелы могут мешать правильной работе формул. Функция СЖПРОБЕЛЫ (TRIM) удаляет начальные и конечные пробелы из строки, оставляя только по одному пробелу между словами. Синтаксис:

=СЖПРОБЕЛЫ(текст)

Функция ПЕЧСИМВ (CLEAN) аналогична функции СЖПРОБЕЛЫ за исключением того, что она удаляет все непечатаемые символы. Функция ПЕЧСИМВ особенно полезна при импорте данных из других программ, поскольку некоторые импортированные значения могут содержать непечатаемые символы. Эти символы могут проявляться на рабочих листах в виде небольших квадратов или вертикальных черточек. Функция ПЕЧСИМВ позволяет удалить непечатаемые символы из таких данных. Синтаксис:

=ПЕЧСИМВ(текст)

Функция СОВПАД

Функция СОВПАД (EXACT) сравнивает две строки текста на полную идентичность с учетом регистра букв. Различие в форматировании игнорируется. Синтаксис:

=СОВПАД(текст1;текст2)

Если аргументы текст1 и текст2 идентичны с учетом регистра букв, функция возвращает значение ИСТИНА, в противном случае — ЛОЖЬ. Аргументы текст1 и текст2 должны быть строками символов, заключенными в двойные кавычки, или ссылками на ячейки, в которых содержится текст.

Функции ПРОПИСН, СТРОЧН и ПРОПНАЧ

В Excelимеются три функции, позволяющие изменять регистр букв в текстовых строках: ПРОПИСН (UPPER), СТРОЧН (LOWER) и ПРОПНАЧ (PROPER). Функция ПРОПИСН преобразует все буквы текстовой строки в прописные, а СТРОЧН — в строчные. Функция ПРОПНАЧ заменяет прописными первую букву в каждом слове и все буквы, следующие непосредственно за символами, отличными от букв; все остальные буквы преобразуются в строчные. Эти функции имеют следующий синтаксис:

=ПРОПИСН(текст)

=СТРОЧН(текст)

=ПРОПНАЧ(текст)

При работе с уже существующими данными довольно часто возникает ситуация, когда нужно модифицировать сами исходные значения, к которым применяются текстовые функции. Можно ввести функцию в те же самые ячейки, где находятся эти значения, поскольку введенные формулы заменят их. Но можно создать временные формулы с текстовой функцией в свободных ячейках в той же самой строке и скопируйте результат в буфер обмена. Чтобы заменить первоначальные значения модифицированными, выделите исходные ячейки с текстом, в меню «Правка» выберите команду «Специальная вставка», установите переключатель «Значения» и нажмите кнопку ОК. После этого можно удалить временные формулы.

Функции ЕТЕКСТ и ЕНЕТЕКСТ

Функции ЕТЕКСТ (ISTEXT) и ЕНЕТЕКСТ (ISNOTEXT) проверяют, является ли значение текстовым. Синтаксис:

=ЕТЕКСТ(значение)

=ЕНЕТЕКСТ(значение)

Предположим, надо определить, является ли значение в ячейке А1 текстом. Если в ячейке А1 находится текст или формула, которая возвращает текст, можно использовать формулу:

=ЕТЕКСТ(А1)

В этом случае Excelвозвращает логическое значение ИСТИНА. Аналогично, если использовать формулу:

ЕНЕТЕКСТ(А1)

Excelвозвращает логическое значение ЛОЖЬ.

«Математические функции || Эксель || Строковые функции»

top

Функции Excel для работы с элементами строк

Функции НАЙТИ и ПОИСК

Функции ПРАВСИМВ и ЛЕВСИМВ

Функция ПСТР

Функции ЗАМЕНИТЬ и ПОДСТАВИТЬ

Функция ПОВТОР

Функция СЦЕПИТЬ

Следующие функции находят и возвращают части текстовых строк или составляют большие строки из небольших: НАЙТИ (FIND), ПОИСК (SEARCH), ПРАВСИМВ (RIGHT), ЛЕВСИМВ (LEFT), ПСТР (MID), ПОДСТАВИТЬ (SUBSTITUTE), ПОВТОР (REPT), ЗАМЕНИТЬ (REPLACE), СЦЕПИТЬ (CONCATENATE).

Функции НАЙТИ и ПОИСК

Функции НАЙТИ (FIND) и ПОИСК (SEARCH) используются для определения позиции одной текстовой строки в другой. Обе функции возвращают номер символа, с которого начинается первое вхождение искомой строки. Эти две функции работают одинаково за исключением того, что функция НАЙТИ учитывает регистр букв, а функция ПОИСК допускает использование символов шаблона. Функции имеют следующий синтаксис:

=НАЙТИ(искомый_текст;просматриваемый_текст;нач_позиция)

=ПОИСК(искомый_текст;просматриваемый_текст;нач_позиция)

Аргумент искомый_текст задает текстовую строку, которую надо найти, а аргумент просматриваемый_текст — текст, в котором производится поиск. Любым из этих аргументов может быть строка символов, заключенная в двойные кавычки, или ссылка на ячейку. Необязательный аргумент нач_позиция задает позицию в просматриваемом тексте, с которой начинается поиск. Аргумент нач_позиция следует использовать в том случае, когда просматриваемый_текст содержит несколько вхождений искомого текста. Если данный аргумент опущен, Excelвозвращает позицию первого вхождения.

Эти функции возвращают ошибочное значение, когда искомый_текст не содержится в просматриваемом тексте, либо нач_позиция меньши или равна нулю, либо нач_позиция превышает количество символов в просматриваемом тексте, либо нач_позиция больше позиции последнего вхождения искомого текста.

Например, чтобы определить позицию буквы «ж» в строке «Гаражные ворота», надо использовать формулу:

=НАЙТИ(«ж»;»Гаражные ворота»)

Эта формула возвращает 5.

Если точная последовательность символов искомого текста неизвестна, можно использовать функцию ПОИСК и включить в строку искомый_текст символы шаблона: знак вопроса (?) и звездочку (*). Знак вопроса соответствует одному произвольно набранному символу, а звездочка заменяет любую последовательность символов в указанной позиции. Например, чтобы найти позицию имен Анатолий, Алексей, Акакий в тексте, находящемся в ячейке А1, надо использовать формулу:

=ПОИСК(«А*й»;А1)

Функции ПРАВСИМВ и ЛЕВСИМВ

Функция ПРАВСИМВ (RIGHT) возвращает крайние правые символы строки аргумента, в то время как функция ЛЕВСИМВ (LEFT) возвращает первые (левые) символы. Синтаксис:

=ПРАВСИМВ(текст;количество_символов)

=ЛЕВСИМВ(текст;количество_символов)

Аргумент количество_символов задает число символов, извлекаемых из аргумента текст. Эти функции учитывают пробелы и поэтому, если аргумент текст содержит пробелы в начале или конце строки, в аргументах функций следует использовать функцию СЖПРОБЕЛЫ.

Аргумент количестов_символов должен быть больше или равен нулю. Если этот аргумент опускается, Excelсчитает его равным 1. Если количество_символов больше числа символов в аргументе текст, то возвращается весь аргумент.

Функция ПСТР

Функция ПСТР (MID) возвращает заданное число символов из строки текста, начиная с указанной позиции. Эта функция имеет следующий синтаксис:

=ПСТР(текст;нач_позиция;количество_символов)

Аргумент текст — это текстовая строка, содержащая извлекаемые символы, нач_позиция — это позиция первого символа, извлекаемого из текста (относительно начала строки), а количество_символов — это число извлекаемых символов.

Функции ЗАМЕНИТЬ и ПОДСТАВИТЬ

Эти две функции заменяют символы в тексте. Функция ЗАМЕНИТЬ (REPLACE) замещает часть текстовой строки другой текстовой строкой и имеет синтаксис:

=ЗАМЕНИТЬ(старый_текст;нач_позиция;количество_символов;новый_текст)

Аргумент старый_текст — это текстовая строка, а которой надо заменить символы. Следующие два аргумента задают символы, которые нужно заменить (относительно начала строки). Аргумент новый_текст задает вставляемую текстовую строку.

Например, ячейка А2 содержит текст «Вася Иванов». Чтобы поместить этот же текст в ячейку А3, заменив имя, надо в ячейку А3 вставить следующую функцию:

=ЗАМЕНИТЬ(А2;1;5;»Петя»)

В функции ПОДСТАВИТЬ (SUBSTITUTE) начальная позиция и число заменяемых символов не задаются, а явно указывается замещаемый текст. Функция ПОДСТАВИТЬ имеет следующий синтаксис:

=ПОДСТАВИТЬ(текст;старый_текст;новый_текст;номер_вхождения)

Аргумент номер_вхождения является необязательным. Он предписывает Excelзаменить только заданное вхождение строки старый_текст.

Например, ячейка А1 содержит текст «Ноль меньше восьми». Надо заменить слово «ноль» на «нуль».

=ПОДСТАВИТЬ(А1;»о»;»у»;1)

Число 1 в этой формуле указывает, что надо изменить только первое «о» в строке ячейки А1. Если аргумент номер_вхождения опущен, Excelзаменяет все вхождения строки старый_текст на строку новый_текст.

Функция ПОВТОР

Функция ПОВТОР (REPT) позволяет заполнить ячейку строкой символов, повторенной заданное количество раз. Синтаксис:

=ПОВТОР(текст;число_повторений)

Аргумент текст — это размноженная строка символов, заключенная в кавычки. Аргумент число_повторений указывает, сколько раз нужно повторить текст. Если аргумент число_повторений равен 0, функция ПОВТОР оставляет ячейку пустой, а если он не является целым числом, эта функция отбрасывает десятичные знаки после запятой.

Функция СЦЕПИТЬ

Функция СЦЕПИТЬ (CONCATENATE) является эквивалентом текстового оператора & и используется для объединения строк. Синтаксис:

=СЦЕПИТЬ(текст1;текст2;…)

В функции можно использовать до 30 аргументов.

Например, ячейка А5 содержит текст «первое полугодие», следующая формула возвращает текст «Всего за первое полугодие»:

=СЦЕПИТЬ(«Всего за «;А5)

«Текстовые функции || Эксель || Логические функции»

top

Логические функции Excel

Функция ЕСЛИ

Функции И, ИЛИ, НЕ

Вложенные функции ЕСЛИ

Функции ИСТИНА и ЛОЖЬ

Функция ЕПУСТО

Логические выражения используются для записи условий, в которых сравниваются числа, функции, формулы, текстовые или логические значения. Любое логическое выражение должно содержать по крайней мере один оператор сравнения, который определяет отношение между элементами логического выражения. Ниже представлен список операторов сравнения Excel

= Равно

> Больше

< Меньше

>= Больше или равно

<= Меньше или равно

<> Не равно

Результатом логического выражения является логическое значение ИСТИНА (1) или логическое значение ЛОЖЬ (0).

Функция ЕСЛИ

Функция ЕСЛИ (IF) имеет следующий синтаксис:

=ЕСЛИ(логическое_выражение;значение_если_истина;значение_если_ложь)

Следующая формула возвращает значение 10, если значение в ячейке А1 больше 3, а в противном случае — 20:

=ЕСЛИ(А1>3;10;20)

В качестве аргументов функции ЕСЛИ можно использовать другие функции. В функции ЕСЛИ можно использовать текстовые аргументы. Например:

=ЕСЛИ(А1>=4;»Зачет сдал»;»Зачет не сдал»)

Можно использовать текстовые аргументы в функции ЕСЛИ, чтобы при невыполнении условия она возвращала пустую строку вместо 0.

Например:

=ЕСЛИ(СУММ(А1:А3)=30;А10;»»)

Аргумент логическое_выражение функции ЕСЛИ может содержать текстовое значение. Например:

=ЕСЛИ(А1=»Динамо»;10;290)

Эта формула возвращает значение 10, если ячейка А1 содержит строку «Динамо», и 290, если в ней находится любое другое значение. Совпадение между сравниваемыми текстовыми значениями должно быть точным, но без учета регистра.Функции И, ИЛИ, НЕ

Функции И (AND), ИЛИ (OR), НЕ (NOT) — позволяют создавать сложные логические выражения. Эти функции работают в сочетании с простыми операторами сравнения. Функции И и ИЛИ могут иметь до 30 логических аргументов и имеют синтаксис:

=И(логическое_значение1;логическое_значение2…)

=ИЛИ(логическое_значение1;логическое_значение2…)

Функция НЕ имеет только один аргумент и следующий синтаксис:

=НЕ(логическое_значение)

Аргументы функций И, ИЛИ, НЕ могут быть логическими выражениями, массивами или ссылками на ячейки, содержащие логические значения.

Приведем пример. Пусть Excelвозвращает текст «Прошел», если ученик имеет средний балл более 4 (ячейка А2), и пропуск занятий меньше 3 (ячейка А3). Формула примет вид:

=ЕСЛИ(И(А2>4;А3<3);»Прошел»;»Не прошел»)

Не смотря на то, что функция ИЛИ имеет те же аргументы, что и И, результаты получаются совершенно различными. Так, если в предыдущей формуле заменить функцию И на ИЛИ, то ученик будет проходить, если выполняется хотя бы одно из условий (средний балл более 4 или пропуски занятий менее 3). Таким образом, функция ИЛИ возвращает логическое значение ИСТИНА, если хотя бы одно из логических выражений истинно, а функция И возвращает логическое значение ИСТИНА, только если все логические выражения истинны.

Функция НЕ меняет значение своего аргумента на противоположное логическое значение и обычно используется в сочетании с другими функциями. Эта функция возвращает логическое значение ИСТИНА, если аргумент имеет значение ЛОЖЬ, и логическое значение ЛОЖЬ, если аргумент имеет значение ИСТИНА.

Вложенные функции ЕСЛИ

Иногда бывает очень трудно решить логическую задачу только с помощью операторов сравнения и функций И, ИЛИ, НЕ. В этих случаях можно использовать вложенные функции ЕСЛИ. Например, в следующей формуле используются три функции ЕСЛИ:

=ЕСЛИ(А1=100;»Всегда»;ЕСЛИ(И(А1>=80;А1<100);»Обычно»;ЕСЛИ(И(А1>=60;А1<80);»Иногда»;»Никогда»)))

Если значение в ячейке А1 является целым числом, формула читается следующим образом: «Если значение в ячейке А1 равно 100, возвратить строку «Всегда». В противном случае, если значение в ячейке А1 находится между 80 и 100, возвратить «Обычно». В противном случае, если значение в ячейке А1 находится между 60 и 80, возвратить строку «Иногда». И, если ни одно из этих условий не выполняется, возвратить строку «Никогда». Всего допускается до 7 уровней вложения функций ЕСЛИ.

Функции ИСТИНА и ЛОЖЬ

Функции ИСТИНА (TRUE) и ЛОЖЬ (FALSE) предоставляют альтернативный способ записи логических значений ИСТИНА и ЛОЖЬ. Эти функции не имеют аргументов и выглядят следующим образом:

=ИСТИНА()

=ЛОЖЬ()

Например, ячейка А1 содержит логическое выражение. Тогда следующая функция возвратить значение «Проходите», если выражение в ячейке А1 имеет значение ИСТИНА:

=ЕСЛИ(А1=ИСТИНА();»Проходите»;»Стоп»)

В противном случае формула возвратит «Стоп».

Функция ЕПУСТО

Если нужно определить, является ли ячейка пустой, можно использовать функцию ЕПУСТО (ISBLANK), которая имеет следующий синтаксис:

=ЕПУСТО(значение)

Аргумент значение может быть ссылкой на ячейку или диапазон. Если значение ссылается на пустую ячейку или диапазон, функция возвращает логическое значение ИСТИНА, в противном случае ЛОЖЬ.

«Строковые функции || Эксель || Excel 2007»

top



Источник: studfile.net


Добавить комментарий